Rserve: '*' not defined for "POSIXt" objects

Hey guys,

I’ve created this simple workflow that runs on my Rserve installation on my server:
image

with the R Community Node

However, the job fails. On my R console i see:

Error in Ops.POSIXt(range(rOut[, 2], na.rm = TRUE), 1) : 
  '*' not defined for "POSIXt" objects

What is this error about?

To give some more context. I want to extract data from an R Script and then insert this data into a PostgreSQL. However, I want to avoid to convert all Dates in R into Strings.

Hello @ThoMi ,

you have made a lot of progress in your project!

You mentioned you tried the R Snippet Community Node.
Have you tried the same thing with the native KNIME Node? https://hub.knime.com/knime/extensions/org.knime.features.r/latest/org.knime.r.RSnippetNodeFactory
I would suggest try this one to see if it has a better performance.

Hi @dora_gcs ,
thanks for answering.
Acutally, I did not try the native R Scripting Node, as in our company, the only acceptable way of running RScripts is via the R-Installation on one of our internal servers. For this, we setup Rserve and as far as I am aware of, only the Community R Scripting node supports the Rserve connection. Please correct me if I’m wrong :slight_smile:

Hi @ThoMi
I’m not experienced with KNIME server, said that Rserve (package) is not related to the server but with the R installation. You should be able to run the test in your local desktop as well. All R scripting nodes use Rserve installed, you should be able to do the same job with native.

but besides that… can you share a display of your input testing $date1$ ?

BR

Hey @gonhaddock , thanks for answering.
I would love to use the native R scripting nodes, however, I did not manage to get it work with an remote installation of Rserve on my server. How should the path to remote Rserve look alike and where to configure it in the knime client? Do you have any further tips although you said that you are not experienced with server?