Run workflows in batch mode accessing data sources thru proxy

Dear all,

I run knime workflows in batch mode. It is working quite well in batch mode when workflows direct access to data sources (without proxy). But, when workflows access data sources thru proxy they do not work.

When we run workflows using various data sources (with proxy or without proxy) inside knime they work fine. Thank you for any help.

The proxy configuration is stored inside the workspace metadata. If you want to use the configuration also inside the BatchExecutor you need to set the "-data" parameter to an existing workspace with configured proxy settings. Otherwise a new (empty) workspace is created that does not have the correct proxy settings.

Thank you for information,

considering that I am not familiar with BatchExecutor I need detailed information about "-data" parameter (it is not standard parameter in batch command for KNIME) and where I have to configure proxy setings in workspace.

Have a nice day,



The -data parameter specifies the location of the workspace containing your KNIME workflows (basically the same as the dialog that pops up when you start KNIME). You need to configure the proxy settings in the KNIME GUI and then point the batch executor to the same workspace.

Thank you for fast response, now I understand.

But instead of -data paremeter I use -preference parameter  (E.g. ...preferences="E:\"...) and it works.

Thanks you again,