Scatter Plots default axis limits are taken from all rows, even when preceded by a Rule-based Row Filter/Splitter


I have a simple workflow where I read in a table of features, filter some rows using a Rule-based Row Filter and plot results using Scatter Plot. The problem is that my rows are inhomogeneous, for example even-numbered rows might have features calculated on raw data, while odd-numbered rows have features calculated on normalized data, and they are labeled as "raw" or "norm". The features are the same but the dynamic range for "raw" features could be very different from that for "norm" features. It is easy to select raw or norm using the Rule-based Row Filter or Splitter node, but Scatter Plot seems to set the axis limits based on the full set of data regardless of any pre-filtering. This is unfortunate for the smaller dynamic range data!

I am wondering if there is a work-around that lets Scatter Plot take its limits from the filtered set of data it is being asked to plot? I thought Row Splitter might solve the problem, but it does not! I could re-arrange my data to proliferate the column dimension, or pre-filter prior to loading in to KNIME, but neither option would be a great solution. Seems KNIME should be able to do this and I just need to know how.

Has anyone run into this problem?

Thanks in advance!


Hi Lorena,

I think you are looking for the Domain Calculator node. Compute the domain of the columns (Min/Max values) right before the scatterplot.

Cheers, gabor