Server Error - No RMI and No Host name

Hello All,
After i installed new server on Linux (centOS), i could not star the server, i’m getting 2 main error

  1. WARNING [localhost-startStop-1] com.knime.enterprise.server.config.CanonicalAddress.determineCanonicalAddress Could not auto-detect canonical server address, please set it in the server configuration: Illegal character in hostname at indiex 10

  2. RMI Server:
    com.knime.enterprise.server.executor.rmi.RMIExecutorManagerImpl.shutdown RMI Executor 0 (user: (none), port: 50100, uptime: 02:03:48, status: Stopped, #jobs: <error: Could not acquire workflow executor because the RMI registry at port 50100 cannot be accessed.>) could not be stopped.
    com.knime.enterprise.utility.ExecutorException: Could not acquire slave manager because the RMI registry at port 50100 cannot be accessed.

Can you pl. help?


Hi Rajesh,

I believe that my colleagues followed up with you offline, but for reference.

Issue 1 should be possible to set manually in knime-server.config. Just add the line: com.knime.server.canonical-address=

Issue 2 is due to a running executor blocking port 50100. Checking the running tasks and forcibly killing that process would solve the issue.