Snowflake to Knime

@etor182 , what do you use in DBeaver? Does it work there?

@bruno29a , the connection to DBeaver was very simple. This is what I am using. One thing I did do different was changed the driver to a different version, (version 3.12.7.jar)

@bruno29a , maybe since I am using a different version, your innitial suggestion might be the best approach? If so, how would the URL differ from what I currently use in the Full account name?

@etor182 , the DB URL would be something like:


It took a while, but I was able to get it working!

Thank you!

1 Like

Hi @etor182 , I’m glad to hear that it’s resolved.

Can you please share what the solution was, so that other members of the Community can benefit from it if they find themselves with the same issue?

1 Like

@bruno29a This was the solution. The Snowflake connector doesn’t work well for some reason, but the below worked perfect.

  1. Download the jar file and save it somewhere (Let’s say C:\jarfiles\)
  2. Add the driver to Knime:
  • Go to File → Preferences
  • Go to KNIME → Databases
  • Click on the Add button
  • In the next window, click on Add file, and look for that jar file (from C:\jarfiles\ as per my example)
  • Click on Find driver classes button at the bottom
  • Add an ID and Name at the top (Both can be Snowflake)
  • You can leave the Database type as Default
  • Click OK
  • Click on Apply and Close
  1. In your workflow, add a DB Connector node
  2. Configure the DB Connector node:
  • Choose Snowflake (or the name you gave above) from the Driver Name
  • Add your connection URL
  • Configure your username and password

@etor182 , the DB URL would be something like:


Hi @etor182 , thanks for sharing.

So in the end, you used the Generic DB connector, and you added the driver (jar files) manually. I’m glad my instructions helped.

I’m not sure why Knime’s Snowflake Connector did not work, something that maybe @tobias.koetter can help raise with the Knime Team. Just to be more precise, with the Snowflake connector, the connection was made, but the role/access did not work. However, @etor182 was able to connect and have the proper access when connecting with the generic DB Connector.

1 Like

That is correct.

Thanks for your help! Almost gave up.


Nice one for perseverance @bruno29a and @etor182 :+1:


This is really useful. I was stuck on the Database preferences not recognizing the snowflake driver from any snowflake jar file. This saved the day!


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.