Software updates in KNIME SDK 2.1.0 not working on Ubuntu

I have just installed KNIME SDK 2.1.0 on my Ubuntu box. I just unpacked it on /opt.
I am trying to install packages other than the standard ones and I use the “Software Updates” wizard. I can check the packages I want, but when I click on “Install”, eclipse just stalls and nothing happens.
Any ideas? Is it a (known?) eclipse issue? Misconfiguration perhaps?
Best regards,
Carlos J. Gil Bellosta

Hello, we are currently trying to reproduce this issue. It seems, if in some cases the button click is not propagated. We saw this on Ubuntu 9.10 (Karmic) - are you using the same version? Please try to select the “Install” button and press ENTER or ALT+i - btw, all other buttons should have the same problem. Please let us know, if this solves the problem. Thanks, Thomas

Yes, I am using (X)ubuntu 9.10. And pressing “ENTER” just after selecting “Install” does solve the problem.

I guess this is a bug… Should I expect it to be fixed sometime in the future?

Best regards and many thanks,

Carlos J. Gil Bellosta

Hi, I have the same problem on my Ubuntu 9.10. This is probably a problem of Eclipse itself so there’s nothing that could be solved from our side. Further it seems very unlikely that it will be solved by the eclipse developers since there is already a newer version (Knime is currently based on eclipse 3.4, while eclipse 3.5 is already released). But since that workaround with pressing enter after button-selection or just using the keyboard shortcut works fine and the installation of new packages should be a rather rare incident I think both of us can live with it. :slight_smile:


I think this is a know Eclipse problem on (K)ubuntu. A work around is to execute the following line:


before you start eclipse/knime. You can put everything in a shell script. At least this solved it for me.

So long,