[solved] can not open new workflow

Hi, in a fresh install of Knime 2.7.0 for Linux64, I am not able to open a new empty workflow, regardless of the method I use (from the welcome screen or from the menu using the wizard).

The opening dialog does not close and the program becomes unresponsive.

I do not get any error messages.

I have attached the knime.log file.

Thanks for your help.

Kind regards,



Hi Axel, 

Sorry for the trouble.  Are you familiar with jstack?  You can attach it to your process to see what is causing KNIME to lockup.  Could you post that result here as well?  

It should be something like:

jstack 'knime pid' > 'path/to/file'




Hi Aaron,

thanks for your help.

In the moment I issue jstack 1411 > knime_jstack.txt in a terminal window

where 1411 is the current process id of knime, I get in the terminal from which I started knime:

Quit (core dumped)

and then in the terminal where I ran jstack:

1411: Unable to open socket file: target process not responding or HotSpot VM not loaded

The resulting file knime_jstack.txt is empty.

I want to mention that the program is otherwise behaving as expected, e.g. I can install additional nodes and such, it's just that I can not open an empty workflow and start working...

I also have no problems running other java apps like nixnote or mediathek.

Thanks again for your help.

Kind regards,


I believe the argument -F forces the app to attach, could you give that a try and let me know if it works?  Also, what build of java are you running? Also, are you using openjdk or the one from Sun? We only really have expereince with the later.


Hi Aaron,

this time I used the pid of "java" and not "knime" for jstack (knime being the only java program running) and it produced a stacktrace, which I have attached.

I am using OpenJDK jre7-openjdk 7.u9_2.3.3-1, but as I mentioned, do not have any issues with other java apps, including eclipse.

Many thanks again for your help.

Kind regards,



Hi Axel,

The jstack file helped a lot! You are experiencing a Linux-specific problem that sometimes occurs: KNIME/Eclipse refreshes the list of available printers each time a workflow is opened in order to determine if the "Print..." menu entry can be enabled. Sometimes getting the list of all printers in a network can take quite some time and meanwhile KNIME freezes. If you wait a bit longer it should come back, though. One crude workaround way is to stop stop CUPS on your machine. You may also want to find out, why it takes so long to list all printers.

From the KNIME side we still don't know a way to work around this, unfortunately.



Hi Thorsten,

sorry for my late answer.

Normally, I do not have the CUPS daemon running, because I rarely print (paperless office, you know....). So, I started CUPS, AND... the problem was gone. I would have never thought about that, maybe you could check in knime whether cupsd is running or not.

Thanks for your great help!

Kind regards,


Hi guys,

I am using KNIME under windows on a regular basis and I have no problems. Recently I switched to linux and I have similar problem. KNIME version is 2.11.3 and is installed from "KNIME + all free extensions for Linux" zip archive on 64 bit Arch linux.

When I want to create new workflow, KNIME freeze and I can stom KNIME only by kill command. This also happens when I'm loading the example workflow.

I have attached the output from jstack command. What could be the solution?

Another problem is that KNIME cannot find the OS web browser and I cannot use node description functionality. I also noticed that this reflect on the KNIME update. I have Chromium installed but what other library do I need in order to use this function.

Same problem as before: KNIME is stuck while querying the available printers. Either your CUPS server is slow or not running at all.

As for the browser issues please read https://tech.knime.org/faq#q6