[SOLVED] Error on adding a group in a report

Dear,

I always get the following error when trying to add a group to a table.

  An unexpected internal exception occurred. Please see log for detail.    Plug-in Provider:Eclipse BIRT Project    Plug-in Name:BIRT Designer UI    Plug-in ID:org.eclipse.birt.report.designer.ui    Version:4.5.0.v201506092134    Error Code:Error.GUIException.invokedByUnexpectedException    Error Message:java.lang.NullPointerException

I even get this in a new workflow with only one node (data generator) sending data to the report.

I also notice that the "edit", "remove",... buttons are not greyed out when no groupings exist yet, while before, only the "Add" button was active and the other buttons were greyed out... see screenshot

behaviour predictions bound to outsmart you into buying

Is this all a (known) bug? I have this with Knime 3.2.1 (I also had it with older versions)

Best regards,
Koen

 

I kept on having more problems... and then I saw some mentions about GTK in the error messages...

So I tried to switch to GTK2 using this solution https://tech.knime.org/faq#q32 

--> ALL PROBLEMS SOLVED NOW... is this known???

Hi Koen,

no sorry we were not aware of this specific issue with GTK3. Thanks for reporting it!

Best regards, Iris