[Solved] Problem reading xls with grouped columns

I have some xls-sheets which I would like to manipluate with Knime.
This xls has grouped columns. This hides some complexity from the user as he can hide or unhide the groups.
When I use the xls-reader node I faced the problem that hidden groups are not imported by the node.
So I face some challenges:

  • The hidden columns have important values which I would like to use
  • When the groups are hidden I don’t get that data (column) at all. When groups are unhidden I get the columns and I need to react in the correct way to these two situations

Is there any chance to preprocess the xls file to avoid that issue?
Or is there a feature which allows to read always also the hidden (grouped) columns? That would be the best solution.

Hi @knimediger

Did you notice in the XLS Reader Settings tab, below More Options: the checkbox “Skip hidden columns”? When you uncheck this it will read in all your columns.
gr. Hans


Hi @HansS,

Thanks for pointing out this option.
Unfortunately the whole section “more options” is disabled. So there is no chance for me to untick the “skip hidden columns”. I checked it with two different EXCEL tables (a g´huge one and an simple one.

I also tried to set the flow variable “SKIP_HIDDEN_COLS” to true in the second tab. But this did also show no changes.

Any more ideas what goes wrong? Are there any other general settings?

1 Like

Hi @knimediger

I think this has a relation with the bug described in this post https://forum.knime.com/t/xls-reader-more-options-do-not-work/16718

gr. Hans


Hi @knimediger,

The issue @HansS linked was only present in version 4.0.0. and was resolved in v 4.0.1 so if you are using the former version update should resolve your problem.



Thanks both @ipazin and @HansS han,

An update of Knime to 4.0.2 solved the issue.
Now I’m able to read the whole EXCEL file with all columns.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.