Some R-Knime visualizations

Hi everybody I am sharing some R-Knime visualizations which I consider helpfull. You need to install the packages in your R before running the workflow. The packages are: treemap, d3treemap and tabplot

Enjoy

 

 

R on Macintosh is throwing the following error when trying to install treemap.

> install.packages("d3treemap")
Warning in install.packages :
  package ‘d3treemap’ is not available (for R version 3.3.2)

Any thoughts?

 

HI Mau!

I think that is a problem in your file. Can you take a look?

Hi tgb417 I made a mistake the name of the package is d3heatmap 

so it should be:

install.packages("d3heatmap")

https://cran.r-project.org/web/packages/d3heatmap/d3heatmap.pdf

Sorry about that.

 

 

Hi Fabio, I checked my workflow and works fine, can you tell me what does not work?

 

Thanks for the responce.  I did eventually figure this out by looking at the code.

Still having an issue with one of the nodes.

 

Hi what I did in order to run is:

1. Reset the itableplot() node 

2. Configure the itableplot() node

3. Click eval script 

4. After a few seconds a new browser window should appear https://s13.postimg.org/8snr9brfr/Captura.png

Tell me if it worked

Best Regards

 

 

Hi Fabio did you managed to see the plots?

Best Regards

 

Hi Mau!

Actually, I can't download your workflow and I don't know why.

I've tried your steps.  I'm not getting the browser window in step 4.

 

Hi Fabio try with this workflow, tell me how it goes

Best Regards

 

 

Hi tgb417, try with the "Execute and Open Views Option"

Please see the image. 

Tell me how it goes.

https://s11.postimg.org/4ka1tpi6r/Open_Views.png

 

Execute and Open view does not help.  Still geting no browser or image.

In the console I get...

ERROR R View (Table)       0:25       Execute failed: R evaluation failed.

No error when I evaluate from within the node.

 

Hi,

Did you know you could package it this way :

Sorry it's in french...

Mau! Worked using your zip file but I still don't know why I can't download extensions .knwf

I am sorry because I do not know why is not working

 

I am happy that is working and regarding the *.knwf extension probably you should update knime because is weird.