String replace inconsistency with Knime 3.7.1

Hi,

Having an issue with string manipulation/replace.

We have a molecule in a cell as a string as seen below:

We are trying to replace certain characters with string replace or string manipulation.
First execution of sting replace erroneously removes most of the content as seen below:

After resetting string replace and executing it the 2nd time we get the correct change:

I would expect a node to always do the same thing no matter what. Any suggestion?

Hi @gmakara,

that sounds weird indeed. Can you upload a small version of your workflow so we can reproduce your problem? How does the replace function in your string manipulation look like?
Cheers,
Johannes

Unfortunately, when I simplify the workflow it always gives the same result, but when it is run as part of a big one then it changes.
Here is the replace window:

Thanks.

I just tried to reproduce your bug, but failed. Works fine for me 100% of the time.

Yes, it does for me too when it is put into a small test workflow. it keeps changing though in my large real workflow. I will try to come up with a test that fails and upload it.

2 Likes