String to Number Problem after excel import

Hi everyone,

I hope sb can help me with the following problem:
I want to import an large excel file (27k rows). After the import every column has “String” a type. There is a column wich must be a Number, because there are the values I want to sum up later. Format is “XXX EUR”. I have already used StringReplacer node to delete the “EUR” but every time I run String to Number I get an error message: “Values in 12436 cells could not be parsed, first error: 224 (RowKey: Row10, Position: 13)” Row 0 to 9 are empty, so that is maybe why the first error is in row 10.

Thanks for your help!

Hi @Tobias_K

Could you post a minimal example workflow with some dummy data that demonstrates the problem? This is probably a pretty easy fix, but it’s hard to determine what the issue might be just from the description. Thanks!

Thanks for the fast reply. Here is a screenshot:
image
That is the actual start of the workflow. I would be the easiest way to share the hole thing, but the excel sheet contains unfortunally confidental info :frowning:
I really do not understand this. For Example, if I check the box for column heads ind the xls reader node, it is no problem and the columns are Double after import. But if I leave it unchecked (what I must do, because the names of the columns change from time to time in the xlsx file) the described problem occurs.

Is it possible to recreate the workflow using some non-confidential dummy data? I have a suspicion that the problem is somewhere in the configuration of the String Replacer or String to Number nodes.

Another idea I just had - since you’re not using the header rows anyway, can you just skip them entirely in the Excel Reader node? Like this:

Then you can assign column names yourself later, and possibly avoid the variable conversion issue altogether.

4 Likes

This worked perfectly! Thanks for your help!
I did not see this option…

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.