Strings To Document Node is not working

Hi Team,

I am trying to use Strings to Document node, but it is giving an error and I am unable to use this node. Can someone please help me to resolve this issue?

Attaching screenshot and sample workflow for an example of this error?


Testing.knwf (11.8 KB)

Prem Kumar R

Hello @premkmr1 ,

on my machine it works.


Is the example the same of your original workflow or is it somehow different?

Have a nice day,

Hi @lelloba ,

Thanks for your prompt response. This is exact workflow which I tried to run in my system and it gave that error, not sure why in my system alone it is not working?

Could it be because of some system settings?

Prem Kumar R

Hello Prem,

have you tried to reset (F8 button) and re-execute all nodes?
Even entering the configuration window of a node and changing few settings might do the job (sometimes it happens to me). :slight_smile:
Unfortunately, it’s difficult to help if I cannot reproduce the problem :sweat_smile:


1 Like

I’m not able to reproduce the error either, but I note there is another node in the top right corner of your screenshot. I wonder if the error exists in your original WF, but not the one you uploaded as an example?

1 Like

Hi @ScottF & @lelloba,

I am not sure, why the problem is occurring only in my system. I have taken the complete screenshot again for your reference.

There are no other node in my workflow apart from the two nodes that I have included in the testing workflow.

Resetting the nodes doesn’t seemed to be solving the problem.

Please refer to the error log which is highlighted. If possible, please let me know how to solve this issue.

If I need to edit my configuration settings, can you please guide me what settings need to be edited?

Prem Kumar R

Strange. Can you quickly clarify what version of KNIME AP you are using?

1 Like

It might also be helpful if you show the whole error message.

“Excecution failed … because xyz”

Hi @premkmr1, I cannot reproduce this error as well. Can you try the following:

  1. Delete this node and drag it again in your workflow from Node repository.
  2. Create a new workflow and drag the nodes from node repository and reconfigure them.
  3. If above mentioned do not work, try selecting the highlighted option from the attached screenshot.

Thank you


I, too, am curious what version of java (java -version) is being used on this system.

I was unable to repro with AP 4.6.3, java 11, and a freshly installed KNIME Textprocessing extension.

java -version
openjdk version “11.0.13” 2021-10-19
OpenJDK Runtime Environment Temurin-11.0.13+8 (build 11.0.13+8)
OpenJDK 64-Bit Server VM Temurin-11.0.13+8 (build 11.0.13+8, mixed mode)


Hi @NDekay,

Thanks for sharing the additional insight. The issue got resolved after I installed latest version of Java and KNIME Text processing extension. Appreciate your guidance.

@ScottF, @Daniel_Weikert and @aliasghar_marvi

Thanks to you all as well for helping me here!!

Prem Kumar R


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.