Tensor Flow and Keras Mismatch Issue


I am receiving an error message that indicates a mismatch between the Keras 2.1.6 and TensorFlow 1.8.0 installed in my Python environment. In the Knime Python Deep Learning Preferences section, the TensorFlow 2 Conda environment indicates that I require a 2.2.0 version as a minimum. How can download the required TensorFlow Conda 2 environement?

I followed all the instructions in the link below and the error still persists

My Python version is 3.7.

I just upgraded to Anaconda 3.




If you have installed Tensorflow 1.8.0, does this, then, mean that you are using the KNIME Tensorflow 1 integration?
If the Tensorflow 2 Conda environment indicates it expects Tensorflow 2.2.0 as minimum, it goes to follow that you would need the KNIME Tensorflow 2 integration to be installed.


Can you confirm which one you have installed/configured?
Also, which version of KNIME AP are you using?


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.