Tes4J - Letters are too large

Hey guys been a while,

I finished the internship for which I developed a workflow in Knime. They are still using it today, YAY!!. However the Tess4J node has stopped providing them output. I have checked all log files and there are no errors. There are some older images it still runs fine, so I boiled down the problem being the fontsize of the printed labels they used.

http://i63.tinypic.com/wkmtj4.jpg

Here is an example of the new input. It looks fairly clean to me.

Any suggestions on tweaking the settings of the Tess4J node as how to achieve this being read as 131?

Current settings of the node are:

It wont post the pictures inline: http://i68.tinypic.com/1zb7955.jpg

 

Hi Luuk,

Congratulations! I hope in your future work you will still use KNIME :-)

About your problem: Seems to be tricky. Can you somehow manipulate the input image such that Tess4J works (e.g. resizing)? Because then we could establish some heuristic: If more than X pixels are "foreground", resize image a bit. You can do that with e.g. "If Switch" in KNIME.

Best,

Christian

Hi Christian, nice to talk to you again.

Well one thing I can confirm that with a smaller print of letters, and with even more letters on there it does work. I tried resizing the image with factor 10 and  0.25 both to no avail.

I tried a different image, same settings as previous, so no resize. Which worked. So apparently the exact size of the image is not the problem..

http://i65.tinypic.com/59t2pv.jpg

EDIT:

Played some with the selection of the labelling area with the interactive annotator somewhere upstream in the workflow. I got one label read now out of 6. It's a start but a long way to go yet.

http://i65.tinypic.com/6rr7rl.jpg

 

Edit2:

Turned off deskew images, 3 out of 6 now. Not sure why, but probably it flipped the images up side down or something would be my guess.

Hi Luuklah,

sorry for the late reply. Did you get it running?

Best,

Christian