Tess4J node - Execute failed: Invalid memory access

Hi Christian,

I just ran the nightly build and no more error for me. However the improved performance I expected of using a smaller image to perform OCR on did not occur. Any hints on that perhaps?

Luuk

Hi Luuk, 

 

although the smaller image is around a quarter of the size of the original image, this will not result in a 4x speedup. I believe tesseract will first find the region containing the text, and that is probably the only operation where the entire image is needed.

Everything else (recognition of a single characters) is still done on the same small amount of pixels as before, for every character independently, where image size has practially no impact on performance. Since most time is probably spent here, and this stays pretty much unaffected by image size, so will the overall execution time.

Also, with the image segmentation step you probably annihilate the performance gain you would get from having smaller images in the first step.

I think you are probably better off chosing "Tesseract Only" as "OCR Engine Mode", if that gives you sufficient results. That is supposidly faster than "Cube Only" or "Cube and Tesseract".

 

I hope this clarifies that missing performance gain a bit.

Greetings, Jonathan

Well its not really that part of performance I'm talking about. I was having an image in which doing OCR based on the entire immage produced a more accurate result then doing it on only the selection.

Doing OCR on the entire image resulted in 100% accuracy. However when I used the cropped image 2 characters were not interpreted accurately. You can have a look in the workflow I sended you, you would probably get the same result.

As for speed I don't really care, because I need the segmentation for other things as well.

Hey Guys,

I installed KNIME on a new machine, downloaded latest Tess4J version, even nightly build site, but this error is back again. However for some reason I am not able to obtain the error log. In the menu of the new install this option is just not present.

 

Luuk

Hey Guys,

I installed KNIME on a new machine, downloaded latest Tess4J version, even nightly build site, but this error is back again. However for some reason I am not able to obtain the error log. In the menu of the new install this option is just not present.

 

Luuk

Hi Luuk,

Oh no! This error seems to keep haunting me. First,please make sure that you are using the nightly update site. I believe the fix for this error has still not been released yet.

Regarding the error log: You can find the log file at "<workspace directory>\.metadata\knime\knime.log".

Regards, Jonathan.

Hi Jonathan,

 I used the nightly update site, atleast I checked the mark before updating. I manually took the logs from the logfile, and attached the part about Tess4J as a file here.

 

Luuk

Just had a check, version of Tess4J I run is: 1.2.0.v201510252148

If I look at the file, this might be the wrong version. 20151025 would stand for 25th of october 2015, and the fix was pushed out in december. Now only to figure out why it didnt take the version from the nightly build site.

Found the problem. Apparently the URL of the nightly build changed. It was tech.knime.org/update but appears to be update.knime.org/ now.

I reported this. Didn't know the URLs weren't synced. Thanks for letting us know.

Hi Chistian,

Any new software update? or we do one need to adjust the software 

"Found the problem. Apparently the URL of the nightly build changed. It was tech.knime.org/update but appears to be update.knime.org/ now."

kind regards

Bassam

Hi Bhassan,

I think the update-sites changed from KNIME 2.12.x to 3.x.x.

The nightly build can now be found at: http://update.knime.org/community-contributions/trunk.

Best,

Christian

 

In trying to resolve the problems I had with the pattern recognition I decided to use an external path for the Tessdata. I just created a folder in my documents, and copied all eng. files to there, and then I was going to try to eliminate them one by one in order to run with the minimal required files. However, now that I placed the tessdata in a seperate folder I get the Invalid memory acces error again.

Knime version: 3.1.1

KNIP version: 1.4.2.

Tess4J version: 1.2.1

Luuk

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.