Trouble with streaming nodes

I am running KNIME v4.3.2 on a desktop. I want to use the streaming function but can’t seem to access it.

I installed the streaming extension per the instructions here: Streaming data in KNIME | KNIME?

However, when I go to create a Wrapped Metanode, I see no option to “Encapsulate into Wrapped Metanode” as is referred to in the above instructions. I only see the option to “Create Metanode”

I have seen other documentation indicating I should simple create the Metanode, and then once it is created, right click on it, and on the menu choose Metanode >> Wrap (or Wrap Metanode). But again, the “Wrap” option is not shown.

I have made sure all nodes are streamable (my current example is a bunch of Rule Engine nodes). These are labeled as Streamable in the node repository section of the my workbench.

How do I check to see that I in fact have successfully installed the extension?

Any help here would be appreciated.

Thanks!

You need to use Crete Component option to use streaming.

5 Likes

Thanks! That was it!

1 Like

Hello @Kapusta,

do you know about KNIME Docs? Among many useful guides it also features search engine so for example you could hit “streaming” into it and that would lead you to KNIME Components Guide…

From within KNIME go Help → About KNIME Analytics Platform → Installation Details and will get list of installed extensions.

Br,
Ivan

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.