Troubles with installation of Redfield NLP Nodes.


I have tried to install Redfield NLP Nodes but got an error:

Cannot complete the install because one or more required items could not be found.
Software being installed: Redfield NLP Nodes (
Missing requirement: Redfield Textprocessing extension for KNIME Workbench (se.redfield.textprocessing.plugin requires ‘osgi.bundle; se.redfield.bert [0.2.0,1.0.0)’ but it could not be found
Cannot satisfy dependency:
From: Redfield NLP Nodes (
To: org.eclipse.equinox.p2.iu; se.redfield.textprocessing.plugin [,]

Does anybody know where can I get this extension?


Hello @dbolshev

It seems that you trying to install the old version of the extension, which is most likely not supported anymore. Are you using Knime older than 4.6 or 4.7?

The current version is 1.1.1:

Could you please try to install this one.

Hello, Artem.

Thanks for reply!

I use KNIME 4.7.2 and try to install the extension from menu: File → Install KNIME Extensions

Could you please then show the list of your update sites?

I have just updated my 4.7.1 instance to 4.7.2, deleted Redfield NLP Nodes and installed them again without any issues. I installed version 1.1.2.

Here is my list of update sites.

Perhaps you have the update site the refers to an old version.

Here it is

I can see the difference now. You do not have KNIME Community Extensions (Experimental) active. I have just checked it and found out that Redfield NLP nodes are part of this update site.
Could you please activate Experimental update site and try again to install the extension?

1 Like

It works. Thanks a lot!


Sorry, but I prematurely solved the task. It has empty packages for Redfield BERT and NLP Nodes.

So after installation nothing changes. Do you know some alternative sources to install from?

Have you tried to click on Finish button? Maybe the size was wrongly defined?

Otherwise you can check if any other versions of these extensions installed. You can check it if you click Help → About Knime… → Installation details, there you will find a list of installed extensions. If you have other versions of BERT or NLP nodes installed, please delete them, restart Knime and try to install the latest versions again.

1 Like

Yes, I tried to click on Finish. Firstly, nothing happened. But after 30 minutes KNIME told I need to restart it to apply changes. So, it works now. Thanks for your help!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.