Unable to configure JSON Transformer

Hi Knimers,

I was developping a worklow to transform a table format to a JSON one. One of my workflow node is the ‘JSON Transformer’ and it was working well.

Today I updated Knime from 3.7.1 to 3.7.2 and I am not able anymore to configure this node.
I tried the double click with the left mouse, the right click and then select ‘Configure’ and also the F6 button but I I am not able to open the windows dialog.

Does anyone have this issue ?

For your information, I am using other JSON nodes like ‘Table to JSON’ or ‘JSON Combiner’ and I do
not have this issue.


I cannot replicate this with 3.7.2 on macOS (10.13.6) - are there any errors reported in the KNIME Console or either of the log files under your workspace’s .metadata directory?

Does it change anything if you drop a new JSON Transformer node into your workflow? If you make a new workflow from scratch? If you upgraded from within KNIME from 3.7.1 to 3.7.2, what happens if you download a fresh whole version of 3.7.2 from knime.org?

1 Like

Hi Quaeler

I have an error in the log file Under the .metadata directory, I paste it below.

I already tried to drop a new JSON Transformer node in my workflow or to create a workflow from scratch but I still have this issue.
I will try to download the 3.7.2 from the website.

!ENTRY org.eclipse.ui 4 0 2019-05-01 20:59:16.090
!MESSAGE Unhandled event loop exception
java.lang.NoClassDefFoundError: org/knime/core/node/util/rsyntaxtextarea/KnimeCompletionProvider
at org.knime.json.node.patch.apply.JSONPatchApplyNodeDialog.afterNewColumnName(JSONPatchApplyNodeDialog.java:117)
at org.knime.json.node.util.RemoveOrAddColumnDialog.addContentsToSettings(RemoveOrAddColumnDialog.java:148)
at org.knime.json.node.util.RemoveOrAddColumnDialog.(RemoveOrAddColumnDialog.java:130)
at org.knime.json.node.util.RemoveOrAddColumnDialog.(RemoveOrAddColumnDialog.java:113)
at org.knime.json.node.patch.apply.JSONPatchApplyNodeDialog.(JSONPatchApplyNodeDialog.java:85)
at org.knime.json.node.patch.apply.JSONPatchApplyNodeFactory.createNodeDialogPane(JSONPatchApplyNodeFactory.java:100)
at org.knime.core.node.Node$1.run(Node.java:2140)
at org.knime.core.node.util.ViewUtils$3.run(ViewUtils.java:353)
at org.knime.core.node.util.ViewUtils$2.run(ViewUtils.java:155)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.ClassNotFoundException: org.knime.core.node.util.rsyntaxtextarea.KnimeCompletionProvider cannot be found by org.knime.json_3.7.1.v201901281201
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:484)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)

Yes - this is a problem related to the architecture change that happened between 3.7.1 and 3.7.2 - please try a fresh download and let me know if the problem evaporates.

I downloaded the last version from the website and now it works.
Thanks quaeler for your help.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.