Unable to Delete User

Logged in as knimeadmin ( AWS server image). I am unable to delete or edit users.

Error: You do not have the necessary permissions. (status: 403, status text: error).


What can i do to fix this ?

Hi @Chris_WK,

this shouldn’t happen if the knimeadmin has still all admin rights. I would like to see the server logs, so I will send you a message on how to proceed further.



We are facing the same error in our environment. Please let us know if there is a resolution to this problem.

Not a solution as of yet, Michael is working on it.


Thanks for the status update, @Chris_WK. We have no solution as of now.

@gunturi4553 is it the same behavior as documented by Chris, so you can’t edit or delete any users with the main administrator account? Did you update your server recently, which versions are used?


I created another admin account even though I thought my licences have been depleted. I was unable to delete the user(with the new admin account). After that test I was able to delete the new admin user. I tried deleting one of my other users that was also successful.

But the specific user that needed deleting still cant be deleted.

@Michael - Yes, it is the same behavior as experienced with Chris. I am unable to delete accounts with the original Admin ID. I created a new Admin ID and experienced the same issue. From the logs "cache update failed ". No changes were made on the server, no upgrade, nothing. It is locked down, so no one has admin access except me. All this started when I tried to create a new group for a user to on-board them, i could not modify their groups, then i tried to delete and recreate that user ID and that is where i faced all these issues. Cynthia sent me a new license key, same errors.

I am trying another approach of completely uninstalling the existing server (version 4.0) and starting with a brand new installation (version 4.1) as I can do an upgrade, which is needed for us. Lets see if that works.

@MichaelRespondek have you been able to do some more research on this subject ?

Chris, due to time constraints, I had no other option, but to completely uninstall and reinstall KNIME server. Now I am able to delete / create / modify users and groups.

I am not sure why this happened, but it is not confidence inspiring, especially when we are trying to promote KNIME as the platform of choice for our organisation. We are also planning to expand into AWS cloud, so we want to be absolutely sure that the KNIME server is reliable and robust to handle our workload.

I will setup some time with Cynthia to get our current and future deployment reviewed. We could use some guidance on best practices for KNIME server deployment.

Hi @gunturi4553
I am really sorry you had this problem.

Currently we were not able to recreate this in our testing scenario. We are very eager to get this fixed. We will keep on debugging this to find a solution so that this won’t happen again.

Thank you for doing the re-installation, so that you have an up and running system.

Upgrading our server from 4.9.0 to 4.9.3 resolved this error. Thanks @MichaelRespondek

It seemed to be limited to two single users. According to Michael this could be related to Usernames containing special characters.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.