Unable to download file


I am struggling to get the server to download existing files on the server (so without the tempdir node). I have an excel file which contains the template of a pivot table. I wish to update the raw data in one of the sheets and afterwards offer the altered excel file for download. The user would then only need to refresh the data in the pivot table to obtain a fresh analysis.

However i cannot get the server to offer up the file for downloading. I've attempted to offer (as a test) a fixed string to the file location on the server to as a variable to the file download node. I've also tried the list file node and offer the file location as a variable to the file download node, but everytime the file download node tells me the the filename does not denote an existing file. I've already been at it for several hours, but i can't get it to work. What am i doing wrong?

It's not possible yet to download files from the server repository via the WebPortal. You can only download files created via the Create Temp Dir node.

I have found a way to do it. It is indeed not possible when using the absolute URL or the mountpoint-relative URL from the server perspective. After studying how the create temp dir node works i discover it uses the absolute server path, eg apps/home/bin etc. By using that type of path i was able to feed in a string to the File download node which actually worked. It only took me 1.5 days of trying to get there :(

I have to say, the documentation on the quick nodes and the server functionality is pretty basic. It would have saved me a lot of time if it was properly listed what is possible and what not. Also it would be nice if the server frontend node execution and the server side execution of the same workflow would be more in sync. Some workflows do work on the server side but do not execute from the web frontend.