Unable to increase available RAM via knime.ini

Hi,

In a newly installed Knime instance i noticed i had a max heapspace of 455mb. I tried increasing this in the knime.ini file (to ~4GB) but that didn’t help.

I looked through the log (see below) and noticed the following that upon starting Knime sets a max mem parameter of 455mb.

2019-05-27 08:43:19,437 : INFO : main : NodeLogger : : : # logging date=Mon May 27 08:43:19 CEST 2019
2019-05-27 08:43:19,437 : INFO : main : NodeLogger : : : # java.version=1.8.0_152
2019-05-27 08:43:19,437 : INFO : main : NodeLogger : : : # java.vm.version=25.152-b16
2019-05-27 08:43:19,437 : INFO : main : NodeLogger : : : # java.vendor=Oracle Corporation
2019-05-27 08:43:19,437 : INFO : main : NodeLogger : : : # os.name=Windows 7
2019-05-27 08:43:19,437 : INFO : main : NodeLogger : : : # os.arch=amd64
2019-05-27 08:43:19,437 : INFO : main : NodeLogger : : : # number of CPUs=8
2019-05-27 08:43:19,437 : INFO : main : NodeLogger : : : # assertions=off
2019-05-27 08:43:19,437 : INFO : main : NodeLogger : : : # host=LTP-107778
2019-05-27 08:43:19,437 : INFO : main : NodeLogger : : : # max mem=455MB

This parameter is not set in my knime.ini file. Does anybody know where this parameter is set, and how I should change this?

Kind Regards,

Maarten

What does the -Xmx line in your Knime.ini file look like?

When “max mem” is reported, it getting that by asking the Runtime what the maxMemory() is, which is a value that will usually be less than the -Xmx specification (for example, in my 3.7.2 release .ini i specify -Xmx2048m but the 'max mem` is logged as 1820MB;) see here for a discussion.

1 Like

Thanks for your reply. How do i increase the maxMemory() then?

My laptop has 16GB of ram and 8 cores, so the 455mb boundary is very limiting

The way to increase it is by configuring -Xmx argument in knime.ini Could you share with us how does your knime.ini file look like?

My knime.ini file looks like this. Its the same as a colleague, who does not experience my problems…

-startup
plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
–launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.551.v20171108-1834
–launcher.defaultAction
openFile
-vm
plugins/org.knime.binary.jre.win32.x86_64_1.8.0.152-01/jre/bin
-vmargs
-server
-Dsun.java2d.d3d=false
-Dosgi.classloader.lock=classname
-XX:+UnlockDiagnosticVMOptions
-XX:+UnsyncloadClass
-Dsun.net.client.defaultReadTimeout=0
-XX:CompileCommand=exclude,javax/swing/text/GlyphView,getBreakSpot
-Xmx8132m
-Dorg.eclipse.swt.browser.IEVersion=10001
-Dsun.awt.noerasebackground=true
-Dequinox.statechange.timeout=30000

Copy-pasting your knime.ini i can start a fresh 3.7.2 installation with large heap size. So the issue is potentially not with content.

I never bumped into such issue, but I noticed, that you use Windows 7. Where do you install KNIME? Could it be that the path is too long? See the note in this section, for example

If you change Xmx to something teeny - like 350MB, does it affect what you see in the log file (i.e is it really reading this file and that parameter?)

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.