Unpivoting Nodes drops missing rows


Can someone please help with unpivoting node where if all the rows are blank, it drops it completely.

I have attached the dummy data and flow.

Desired result is it keeps all the rows while unpivoting and spits out blank cells in column name and column value with ID, Status and Dollar columns.


Book1.xlsx (10.8 KB)

Test.knwf (9.5 KB)

Hello @akngnew ,

uncheck this box and you will have missing cells back.

Have a nice day,

1 Like

Hi Raffaello,

Thanks for your prompt reply. I tried that already. It gives me 40 rows when my data only has 10 rows. I only need the 10 rows but where levels are blank they should also be included in the data. At the moment unpivot is excluding the the 2 rows which have no levels and giving out only 8 rows. Thanks.

So you need the 8 rows + the 2 with missing data, correct?

1 Like

Perfect it worked. Many Thanks. Can I please ask if there is a way that the excel writer gives out the date in Australian format instead of US format?. Also is it possible to get the columns bit extended and formatted… for example amounts formatted by commas etc. Thanks Akash.


Hi @akngnew ,

at the previous link you will find an updated version of the workflow. I have added a field called “date” containing the actual date. Since it has been formatted as Local Date, Excel should read it according to your locale settings. Tell me if not so.

Have a nice day!


Many Thanks. Can you please have a look at my request called create space and count. You did the initial workflow and now I have attached the input and output data for you reference.

Thanks again.

Sorry @akngnew , I missed your reply. Tag me (using @) so I can receive notifications. Also, please mark this post as “solved” so we can close it, if you have found your solution :slight_smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.