Unsupported column type '?' shows on Excel writer

I have a functionning workflow it worked well for one input excel file. when i tried with new input excel file with different data i got the below problem “Execute failed: Unsupported column type ‘?’. Please remove corresponding column(s) from the input table.”

I noticed that, for one input file at the output node all columns have string data type mentioned at the top but for another input file it has “?” instead of having a data type.

But both file has same kind of data
So is this a source of problem ?

Check the Excel data types in your failing input table. The data may “look the same”, but have some strange data type.

Hello @BAVITHRA,

You can check the column data types.

If possible, could you please share a sample of the data?


Both data has empty values inside in this Qty column doesnt have any issue for the 2 different input file
Data without issue

Data with issue

Hi
I have attached the images of data
can you please help?

Please help us to help you.

If you give an example with data, we will be able to help you better.
Attach your workflow and provide some example data.

Br

I @BAVITHRA

I’m assuming, based on the images, that you are importing the data using an Excel Reader node.
I can see that you are not configuring it to convert the first row of data into headers.
Therefore, it imports the headers as if they were data.
Each time you reset the node and execute it, it will automatically try to identify the data type of the columns, based on a few rows of data. In the first case, there is enough data for it to make a decision and automatically indicate the data type. In the second case, there is not enough data, due to the lack of sufficient elements of the same type. Hence the ‘?’.
In the Excel Reader node, you can configure and force the data type of each column.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.