Update to KNIME 4.3

I’m trying to update KNIME to 4.3 via the File/Update KNIME… feature.

However my computer stops connections via https. For the extensions I have changed to http which works well but when I try to change to http for https://update.knime.com/analytics..../4.3 in Preferences/Install/Update the change will revert as soon as I execute update KNIME. I guess the link is hard coded somewhere and ignores the change made in Preferences. Anybody who knows a solution?


May I ask in which environment you are facing this issue? Is it in a private or enterprise environment with a KNIME Server?

In the latter case your IT Administrator could have denied changing the update sites on purpose.

This can be used to prevent that workflows assembled on newer versions of the Analytics Platform using new features won’t run on an older KNIME Server version.


Hi, thanks for following up.

It is an enterprise environment. But KNIME is not on the IT Admin radar and such a target logic is not in place, that I’m sure.

When I ran KNIME extensions they did not work either with https but changing to http works. I see when I ran the update, that it reverts back to https and try to connect getting an error due to enterprise block. Anyways if there is no quick solution it does not matter so much. After I wrote the first post I downloaded the full 4.3 and did a new install. But would prefer not to do that for 4.4 version if possible.


Hello @sammyhallgren,

and welcome to KNIME Community!

Seems to me this is more Eclipse related (on which KNIME is built) so here you should find information you are looking for (and a bit more):

However maybe give a try to allow connections via https?


1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.