Updating KNIME

Hi,

I'm unsure if I'm the only person who experiences this problem, but over the last few months I find it very difficult to update KNIME through the community releases. It takes an age to carry out, and normally requires several update attempts for the updates to work, I usually get server timeout error boxes, especially when the progress bar is at 35%. This occurs on different PCs and at different locations (i.e. different networks).

Message is "Updating Software has encountered an error" Unable to read repository ..... Read timed out.

Any ideas on what the issue is?

Thanks,

Simon.

Not really. The only thing that comes to my mind is that the IP from you are coming is making too many connections to our server. We block such hosts because we have frequent attacks on our server. I can raise that limit a bit and you may check if it helps.

Hi Simon,

Do you experience these problems also when you connect through your internet connection at home? (I think I remember that your corporate internet connection is somewhat "exceptional".) One problem could be that the contributors to the Image Mining extension are extremely active (I see updates everyday) and their plugin is relatively large...

Thanks,
  Bernd
 

Hi Bernd,

Well yes, the corporate internet connection is somewhat "exceptional" and if it was purely happening at work I would put it down to that.

However, I am finding it is happening just as often at home. Almost daily there is an "Image Mining" update to put on, and I would say this takes about 4 attempts to go on. The other week, it took about 3 attempts to update to the latest RDKit and also to the latest Indigo, I am unsure why its become like this over the last few months. I never used to have this problem before.

There is no way I can select multiple updates to go on at once, that always fails. I find I need to do one at a time now.

Simon.

Hi,

I have now managed to pin down where the issue is. The files download completely when you look in the Details part of the "Updating Software" download window, it gets all the way to 100%. KNIME then pauses for a while before reporting the error mentioned above.

It happens for most updates now, RDKit, Palladian, Image Processing etc..

I have eventually solved the problem by changing the -xmx1024 to -xmx512 in the knime.ini file. Having made that change, everything installs perfectly now,why is this.

This applies to both my PC and the Office PC, both are 32bit windows (one is Vista, the other is XP), they both have 3Gb RAM too.

Anyway, its working now, but I dont know if there is an underlying problem somewhere.

Simon.

Does anybody still encounter this while trying to update or add extensions? Recently in the past few weeks, I've had a lot of issues accessing the community contributions, the community stable contributions and the nightly trunk. I've tried adjusting the JVM memory per the above post, but was unsuccessful. 

This is the error I'm getting — it's like it grabs the jar file, and downloads about 75% of it and gets stuck (I also tried this in the browser, and encountered a similar result): 

eclipse.buildId=unknown
java.version=1.8.0_60
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments:  -keyring /Users/chrisatwood/.eclipse_keyring -showlocation
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -keyring /Users/chrisatwood/.eclipse_keyring -showlocation

org.eclipse.equinox.p2.transport.ecf
Error
Fri Oct 21 16:26:20 CDT 2016
Unable to read repository at http://update.knime.org/community-contributions/trusted/3.2/content.jar.

java.net.SocketTimeoutException: Read timed out
    at java.net.SocketInputStream.socketRead0(Native Method)
    at java.net.SocketInputStream.socketRead(SocketInputStream.java:116)
    at java.net.SocketInputStream.read(SocketInputStream.java:170)
    at java.net.SocketInputStream.read(SocketInputStream.java:141)
    at org.apache.http.impl.io.AbstractSessionInputBuffer.read(AbstractSessionInputBuffer.java:198)
    at org.apache.http.impl.io.ContentLengthInputStream.read(ContentLengthInputStream.java:178)
    at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:137)
    at java.io.FilterInputStream.read(FilterInputStream.java:133)
    at java.io.FilterInputStream.read(FilterInputStream.java:107)
    at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer$1.performFileTransfer(AbstractRetrieveFileTransfer.java:178)
    at org.eclipse.ecf.filetransfer.FileTransferJob.run(FileTransferJob.java:73)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Hi,

"Read timed out" sounds as if the connection isn't reliable. Maybe you can just download the zip archives of the update site and install from there?!

Regards,
 Bernd