Upgrading many deprecated nodes at once

#1

I have a huge workflow developed in version 3.x with a number of Deprecated nodes. How can I replace existing Deprecated nodes with the latest versions? (examples: String To Document, Abner tagger, many more…)

Thanks!

0 Likes

#2

You can’t and I know the pain. We started on knime 2.7…This is in my opinion one of the biggest downsides of knime. By default it’s ok because behavior else might change but there should be an update option for such trivial cases at least.

Same problem with DB nodes, quick forms vs configurations etc. I’m gonna say takes more maintenace than code :frowning:

0 Likes

#3

I agree partly. This is definitely something we are working on.

However

  1. you do not need to replace them. They will continue working just fine.
  2. The DB nodes actually have a auto replace option. It is currently not so visible, but we will improve this for 4.1. which will come out tomorrow :slight_smile:
1 Like

#4

@Iris, do you know if new release will support parallel execution of new and legacy DB nodes? Without this option I will not be able to switch from 3.7.2 to 4.1.

0 Likes

#5

Hello izaychik63,
the old and new database framework where designed to work next to each other within the same KNIME Analytics Platform. With KNIME 4.0 we had a problem with Microsoft SQL Server and native authentication which was only usable by either of the two framework but this is fixed with KNIME 4.1 which will be released tomorrow.
We are aware that a lot of users have many workflows with many database nodes in them. That is why we introduced the new workflow migration tool which replaces the legacy database nodes with the equivalent new database node and also tries to migrate as much of the settings as possible. We plan to extend the usage of this tool to other nodes in the future to make it easier for you to migrate to the new versions of an existing node.
Bye
Tobias

3 Likes

#6

Thank you, @tobias.koetter. Could you please provide a link on setting Microsoft SQL Server native authentication in new version or it will be enough to add drivers new and legacy in KNIME configuration?

0 Likes

#7

Hi izaychik63,
is it ok for you to wait until tomorrow when we release KNIME 4.1? With the release we will ship all necessary driver files with KNIME and also extend the node description as well as the database documentation with a section about this topic. Otherwise I can send you the information required to do so with KNIME 4.0.
Bye
Tobias

0 Likes

#8

Thank you, Tobias. Will wait for tomorrow.

0 Likes