Waiting Too Long While Fetching 100 Rows Data from Database



I am relatively a new Knime user. It is an excellent product. As soon as possible, when I learn Java programming I will make contributions to the platform. 

For now, I have a problem. I am connected to Oracle database. When ı first open my workflow, I can run a table connection node. But after that, when I want to  connect different database tables, I am waiting too long. When I want to fetch only 100 rows from database I am waiting too long. My memory preference is "keep only small size"... Also when I want to write table to database, I am waiting too long and at last, it does not writes to table. Node says that: "opening database connection"...


How can I solve this problem? 

So many thanks...

is it possible that you are experience network problems because you are waiting for KNIME to connect to the database?
When you experience delays when writing to a database you might want to increase the batch size on the Advanced tab.
If you still experience the problem it would be great if you could provide some more details like how long does it take to execute the node, where is the oracle database located (local/remote), make a screenshot of the workflow.

Hi! Sorry for the late reply. I have solved the issue. It was because of cartesian tables. It was about 4 billion row size which I have wrote to database. :slight_smile: I dropped that table and solved the issue.

Also Thanks for your reply…

Best regards,