windows 64bit

Hi,

I just moved to a windows XP 64 system. I installed the developer version of KNIME 2.1.1 and all extensions, SVN etc. Everythings looks good, compiles and even starts without problems.
Then I import a project that was saved on a 32 bit windows XP system (including data) and try to run a node. I then get the following error message:
Exception in thread “KNIME-Worker-0” java.lang.OutOfMemoryError: PermGen space
Exception in thread “KNIME-TableIO-1” java.lang.OutOfMemoryError: PermGen space
Exception in thread “KNIME Progress Timer” java.lang.OutOfMemoryError: PermGen space
Exception in thread “Thread-11” java.lang.OutOfMemoryError: PermGen space

As this machine has much more memory as the previous one I don’t think this is a memory issue. Can this be a library issue? (Maybe I am using a library that is not compatible with 64 bit), or maybe the import from a 32 bit system into a 64 bit system doesn’t work correctly? (I am having problem with variables and paths when loading a windows workspace into a Linux environment, but that is a different issue…)…

Or do you have any other suggestion on what to check?

thanks,

Bernd

The “PermGen space” error usually happens if quite a lot of plugins are installed in Eclipse. We set the corresponding perm gen space to 256MB in the KNIME Desktop version. If you start KNIME from within Eclipse/the SDK version, you may need to specify the perm gen space size explicitly: -XX:MaxPermSize=256m (for example). Note that on 64bit machines everything needs more memory than on a 32bit system. Thus something that works on your 32bit system need not necessarily work with the same memory settings on your 64bit system.

thats works now perferctly fine. Thanks a lot.
B

Hi,

While updating my KNIME2.3 desktop version, I encountered two strange things:

When updating the underlying Eclipse installation from 3.1 to 3.2, I switched to the Knime-in-Eclipse mode. And from that point on, I also get the germ space error message, especially when trying to install further software. Unfortunately, I have no clue where and on which point I have to input the -XX:MaxPermSize= command. I´m working on a Win7 machine.

 

Thank a lot,

 

aks

Inside your Eclipse installation there should be an eclipse.ini. You can enter the same VM settings as in KNIME there, e.g. -vmargs -XX:MaxPermSize=192m