Workflow did not fully execute (but it did...?)

I have a workflow that has 1 primary data output that writes my main data table to an SQL database and a secondary data output that is used as a control report, in that it takes the data and checks for a condition (a missing mapping from a join from another file), and outputs just a few columns to show where there is a gap in mapping (again written to an SQL database)

For some reason, when I run this workflow, I am getting the ‘Workflow did not fully execute’ and red square, yet I have set it up with an empty table switch and some other logic so everything is actually successfully running (and have checked by manually running it locally)

Here is a screenshot of the main error messages


and here is a screenshot of the portion that is failing

What have I done wrong?

As a note, when there is indeed an empty table, I have branched off to include a lone data value (NO MISSING VALUES) as I don’t want the workflow to not write anything to the table, as otherwise it would leave old data in the table, and you’d think there is still something unmapped.

I have seen elsewhere people mention, but I’m not sure why there are errors messages for other things, for example, I have a large number of these:



Hello @knightyboy,

Where are you getting this message and seeing red square?

List of messages you shown are not error message but warning messages and each one warns you about empty data table which seems to be possible scenario in your flow so wouldn’t worry about those.


The red square appears on the KNIME application against the workflow once it’s been run on our server.


The message appears if I click on the workflow within the WebPortal (version 4.11.3)


Perhaps this message and icon are correct, but to me, it’s saying that my workflow has failed (which it hasn’t)

Hello @knightyboy,

ok. This is regarding KNIME server. Let’s see if someone more acquainted with it can assist you.

Regarding warning messages from Missing Value node have added +1 to existing ticket (AP-13764) to deal with it (not to show this message when column not used in configuration). So think you can safely ignore them.


Hello @knightyboy ,

Based on some research, I recommend including a try/catch node sequence [1] in the workflow. The workflow isn’t actually failing, but because of the warnings and nullified branches, the server may be getting confused about the workflow’s final execution state. So it’s really about mitigating those warnings properly.


[1] try catch – KNIME Hub


Have just tried using that but don’t seem to be having any success as still getting the same Warning messages.

Have just done an upgrade to the 4.12 server version so the message on the WebPortal has changed slightly to ‘Not executable’ rather than ‘Workflow did not fully execute’ as before.

But the workflow is definitely still executing, as the outputs are successfully being created…

just adding an image of how I updated it (it’s not the end version, as I haven’t yet put the branch for when the table isn’t empty)


At second look, maybe the key here isn’t use of Try/Catch. Instead, you might try using the End IF to collect the branches back together from the DB Writer nodes.

If the reason the workflow is throwing warnings at completion is because as constructed, one of the DB Writers is always going to have a red X over the output port, which may be what is causing that “workflow didn’t fully execute” error.

Please test this hypothesis and let us know if it corrects the issue.

Thank you,

Still no luck I’m afraid. Exact same error messages

Not sure why the ‘Catch Errors’ node wasn’t picking up the created table when the empty table was input to the original input node but a concatenate sorted that

hey @knightyboy

Are you sure you do not have any nodes disconnected somewhere in the workflow?

What server version are you using?


Ohhhhhh Ana,

Now I feel like a right twerp!!!

I hadn’t checked one of the metanodes thoroughly enough and indeed there was a disconnected node in there.

Apologies for wasting everyone’s time, but at least I have learnt a lesson!!

Ah, don’t worries – been there, done that (many times as well) Glad that now problem is solved!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.