Workflow keeps old data, even though the input table was changed

Hi there,

I ran into an interesting phenomenon that I cannot now repro. Nevertheless, read me out. This is what happened:

  1. I had a workflow running on 2021 data.
  2. I changed the input table to 2022 data for the new analysis. All nodes got reset, naturally. I checked the Table Reader output and it was indeed the correct 2022 data.
  3. I ran the workflow and to my surprise, the data in the 2nd node remained the 2021 data. :frowning:
  4. I re-checked the Table Reader’s output, like twice, and both times it contained the correct 2022 data.
  5. I disconnected and reconnected the Table Reader node (even though I really shouldn’t) and the problem was solved.

A couple of words about me: I should have become a software tester as I am good at breaking things, but here I really didn’t do anything special.

My OS: Windows 10 Pro.
KNIME 4.7.1

Thanks,
Ribizli

Hi ribizli,

This is a strange issue, can you share an image of your workflow maybe to see where the data is flowing from ?

Thanks,
Keerthan

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.