Workflow requires missing extensions


I downloaded KNIME 4.0.2 on a new computer and went to open an old workflow and it said I was missing extensions. I told KNIME to search and install the required extensions but it just freezes on my computer. Any idea on what is up?


Clicking the “Next” button doesn’t do anything, the dialog box just stays there.
If I manually try to install KNIME says they are already installed.

Hi KenM,

please try to edit the knime.ini-File and add the line


in the first line. Then start knime as usual and try out, if the workflow can be executed.

You can delete the added line afterwards to speed up the start of knime.

Best regards, Micha

Michael, thanks but did not work. I will be at the conference next week so hopefully someone there can help.

Hi there @KenM,

have couple of questions if you don’t mind that might help.

  • you said a new computer. That means there was no KNIME Platform installed on it previously?
  • in what version was that workflow used?
  • what OS are you using? If Windows was it installer, self-extracting archive or zip you downloaded?
  • how did you import your old workspace/workflow?


1 Like


On my old computer, everything worked fine and I was on version 3 (3.6 I think) so all my old workflows were under this version.
Then I transferred to a new department and downloaded KNIME 4.0 on a new computer, there was no KNIME before. In both cases the old and new computer are HP Zbook Studio laptops, Windows based.
When I installed KNIME 4.0 on the new computer, I just went to the KNIME download site and clicked download and the Installer.exe file downloaded and did the self-extracting.
For importing the old stuff, I just copied and pasted from the old computer to the new one in a different folder under “C:\knime-workspace”.
Does that help? I am willing to try anything, even re-download if I have to.
Thank you.

Have you tried to download the zip archive without the installer?



No, but since I am willing to try anything, I uninstalled and deleted everything, then started over using the Zip file instead. Well that worked so for Windows the zip file appears to be a better way then the self-extracting, at least for me. Thank you all.


Hi there @KenM,

glad you solved it :slight_smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.