Workflow variables not being read

I'm trying to run my knime workflow via Ubuntu shell using the batch application, and I have defined a number of workflow variables that I wish to override when running the workflow in the command line. This is my command:


/path_to_knime/knime -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION -reset -nosave -workflowFile="/path_to_workflow/" -workflow.variable=input-url,"/path_to_input/input.csv",String -workflow.variable=input-url2,"/path_to_input2/input2.csv",String -workflow.variable=output-url,"path_to_output/output.csv",String -workflow.variable=delimiter,",",String -workflow.variable=class_column,"Class Column",String


However I get this error everytime:

INFO      main BatchExecutor     ===== Executing workflow /path_to_workflow/MyWorkflow =====
WARN      main CSV Reader     No source location provided! Please enter a valid location.
WARN      main CSV Reader     Input file '/path_to_default_defined_in_variable/default.csv' does not exist
WARN      KNIME-Worker-0 Decision Tree Learner     Class column "Default Class" not found or incompatible
INFO      main BatchExecutor     Workflow execution done Finished in 2 secs (2945ms)
INFO      main BatchExecutor     ========= Workflow did not execute sucessfully ============


It's not using the values I pass to the workflow variables I specified in my command, but instead it keeps on using the default values. It used to work fine before but now it's acting up. I'm not sure if there is a knime setting or workspace I should be checking. Please help, many thanks.


Could you confirm your KNIME version. And also that you are setting 'global' workflow variables.