Workflows won't load

Hi, I run the latest version of KNIME on CentOS in a VBox environment, with no internet connection. I'm finding a major problem with using KNIME is that my workflows don't load after I;ve saved and then shut down the machine - there's no error when I try and reload them, and the nodes are present and correct in my workspace folder, however the workspace editor screen remains blank despite trying several loads. This means I have to take screenshots of every workflow I build to allow me to recreate them when this load failure happens.

An examination of the error log shows that the .knime project file is disappearing, so even though the project folder has all the nodes in place the .xml script is for an empty space (KNIME is creating the new .knime file whenever I try and load the project).

Any help would be appreciated.

I am PhD student and developing my project in Knime. For me this is really alarming to use Knime for my full project because of  sudden loss of fully developed Metanode. I am trying to find the solution for this given issue:

while running workflow Knime gives me message (node is trying to connect with R, data leakage can occur) and was halt. I tried to close it and after closing and again uploading, it uploaded with a lot of errors  and one metanode is missing from the workflow.

The main issue is, in the project folder that metanode have lost the "workflow.knime" file

How can I restore this "workflow.knime" file for that particular metanode node?
Error:
Unable to load settings for node with ID suffix  (My METANODE) : Unable to read settings file "workflow.knime"

would be thankful for any help and guidance.

Hello samina,

This sounds disturbing, yes. Could you please provide us the log-file (when the Analytics Platform starts the location is shown in the console) and possibly a workflow containing the metanode?

Best,
Ferry

Hi,

Thanks for your kind response. 

My Metanode is missing from workflow interface where I can use it. But all data nodes are present in the project folder where all others meta nodes have a file "workflow.Knime" only the missing node that is mentioned in error does not have this "workflow.Knime"  file. It is my observation this error is just because of loss of this file "workflow.Knime".

Now I manually deleted this file in one of example meta node to show you these errors as my original workflow is now saved with missing node and it does not show any error and meta node is still missing. 

Maybe the bold lines in this given error are the actual problem, and I want to know any way to rewrite or restore this "workflow.Knime"  file. 

Best Regards,

Samina

**************************************************************************************************************************Log file is located at: C:\Users\SAMIN\Dropbox\samina PhD work\knime\.metadata\knime\knime.log
WARN  Interactive Table    2:109      Unable to load internally held tables for node "Interactive Table": No BufferedDataTable  with ID 38544055
ERROR LoadWorkflowRunnable            Errors during load: Status: DataLoadError: backpractise_Randomforest 2 loaded with error during data load
ERROR LoadWorkflowRunnable              Status: DataLoadError: backpractise_Randomforest 2
ERROR LoadWorkflowRunnable                Status: Error: Unable to load settings for node with ID suffix 108: Unable to read settings file C:\Users\SAMIN\Dropbox\samina PhD work\knime\backpractise_Randomforest\MetaNode 1 _ (#108)\workflow.knime
ERROR LoadWorkflowRunnable                Status: DataLoadError: Interactive Table 2:109
ERROR LoadWorkflowRunnable                  Status: DataLoadError: Unable to load internally held tables for node "Interactive Table": No BufferedDataTable  with ID 38544055
ERROR LoadWorkflowRunnable                  Status: DataLoadError: State has changed from EXECUTED to IDLE
ERROR LoadWorkflowRunnable                Status: Warning: Image Output 2:110
ERROR LoadWorkflowRunnable                  Status: Warning: State has changed from EXECUTED to IDLE
ERROR LoadWorkflowRunnable                Status: DataLoadError: State has changed from EXECUTED to IDLE

 

Hello Samina,

Sorry for the late reply.
This looks like something corrupted your workflow/workspace. Can you please provide the workflow you ran when the error occured? If you don't want to upload it in the forum you can send me an email via the contact form (below my profile image).

Thanks,
Ferry