Writing txt file, output has unwanted whitespaces

Hi, I’m trying to write tab delimited text files with CSV Writer, but the output file has whitespaces before and after the tab delimiter. Any help would be appreciated how I could write the txt file without the whitespaces. I tried all the different encoding options but it didn’t solve the issue.

Thanks,
Ilkka

image
image

image
image

Hi @Ilkka this seems to happen only around strings:
image

This means it’s happening with quoting Strings, and looking at the Advanced Settings of the CSV Writer, it looks like it’s the default setting:

If you change it to Never, this behaviour does not happen:

image

7 Likes

Thank you Bruno, that solved my problem!!

Best,
Ilkka

4 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.