XLS Formatting - I want Knime to format headers

Hi,
I have KNIME 4.1.0 installed, I found out that in higher version link to SharePoint for some strange reason is not working.
I wrote a very simple flow as I’m a newbie which basically just copy-pastes report one under another once data is uploaded to SP. But, what I don’t like is that the headers, the first row in my database is losing the formatting each time I run the Knime.

It is creating some issues and there are other people using the database to change the rows manually - add comments, rootcauses etc… I read somewhere that a node XLS Formatter should do the job, but it doesn’t work. I installed the extension, restarted the app - like 3 times already and nothing works.
It seems that “Continental” bucket under “Community Nodes” is empty. Yet when I try to instal the node once again, i get the error message saying it is installed. I tried googling the solution but nothing works.

Is there any workaround? All I need is to put some color in the first row or change the database into Excel Table (which would would be awesome if possible).

Thanks!

Hello @MacKol,

welcome to KNIME Community!

Seems to me there are couple of things you are struggling with so let’s go one at the time.

What node(s) do you use to connect to SharePoint? REST nodes? From version 4.2 there is dedicated SharePoint connector node. I suggest to update to newest version and give this node a try. See here for more: https://www.knime.com/whats-new-in-knime-42#sharepoint

What are you referring to with database? Don’t see how it relates to SharePoint? :confused:

Try starting KNIME with -clean parameter. See here for more:

If you are writing data using Excel Writer node it can not preserve formatting so you are on the right way in terms of using Continental nodes to format newly written Excel files. Change database into Excel Table? Still don’t see how database plays into this whole process so you’ll have to explain it a bit more :smiley:

Br,
Ivan

Hey Ivan,
Thanks for quick answer, let me answer your questions as best as I can.

  1. I’m not using any Nodes to connect to SharePoint. I’m using ExcelReader Node to read an excel file that is stored and updated on sharepoint. I tried using the newest Knime version, but it seems I can’t connect to my company’s sharepoint at all.

  2. What does it mean to run Knime with -clean parameter? Can’t find anything in google.

br
Maciej

Holy hell, it worked. I had to spend like an hour or so googling how to run application with “-clean” parameter but I found it!

Here’s link how to do it:

For people like me, here’s a TL;DR:

  1. Go to Start
  2. Type “CMD” and press enter
  3. Put the location of your Knime application on your local disk (f.e. C:\Program Files\Knime) and hit enter
  4. Type “start knime.exe -clean” and press enter
  5. Problem solved :slight_smile: :slight_smile: :slight_smile: :slight_smile:
2 Likes

Hello @MacKol,

glad you managed to figure it out on your own. However this was described in a solution in topic I shared with you in my previous example :wink:

Br,
Ivan

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.