XML reader times out

Hi all, 

I noticed the in KNIME 2.6 the XML Reader node fails with a time-out error much faster than its predecessor in v2.5.4.

For example I used this URL as selected file in the XML Reader node:


and gives me this error:


ERROR XML Reader Execute failed: Read timed out

By slighly increasing the tanimoto threshold to 75 and above (i.e. reducing the length of the response) the same query works:


As I said, this was definitely not the case in 2.5.4.

Is there a fix?


Thanks in advance,


ChEMBL group


We have introduced a timeout of 1 second for all readers since quite a few users complained that slow websites blocked dialogs. You can adjust the timeout by setting the Java property "knime.url.timeout" to a value in milliseconds in your knime.ini (e.g. -D.knime.url.timeout=10000).

Hi Thorsten,

Indeed, by adding this:



in the knime.ini, the problem was solved.

Many thanks,


I'm not sure this is an ideal solution relying on the user to be editing the knime.ini file, it's not particularly user friendly. Is there no way of building in a timeout setting in the node dialog of the XML reader node. At least this way George could update his public workflows so they work straight out of the box.



1 Like

I agree with "richards99"  it's not the ideal solution but it did work for me. However now I've upgrade to knime 2.7.4 it doesn't work anymore. Has there been a change?

I now implement a JPython script which does work since but obviously this is not the preferred way at all.




Do you have to restart KNIME when you change the knime.ini?