03 Aggregation and Data Blending - Exercise – KNIME Community Hub

This workflow shows a hands-on exercise in the L1-DW KNIME Analytics Platform for Data Wranglers: Basics course

This is a companion discussion topic for the original entry at https://hub.knime.com/-/spaces/-/latest/~9EsVjsInBn_nrorC/

Hi! Task 3 asks us to modify some country values manually in a table using the Table Editor node. However, after trying to use that specific node, I have no idea where in that node I’m supposed to edit individual row values. The Solution of the exercise doesn’t seem to be doing anything different from what I did, yet it has the proper edited values in the output.

If we’re supposed to edit through Execute and Open Views, then I’m not sure how to edit values in the JS Table Editor view, because that window only lets me change values based on a predefined dropdown menu. I don’t see any video or text tutorial about that node either, and the node isn’t even mentioned in the course up to that point. Could anyone help me? Thank you. Note: I’m on a Windows PC.

1 Like

Hello @btoulas

Did you have any luck solving this? I am facing the same problem and could not find the answer as well, or any video or tutorial to support it.

Thank you.

Hi @MiFs

Unfortunately no. I’ve tried matching the settings for the table node exactly between my exercise and the solution, but that didn’t change anything. The solution lets me edit the names in the JS view just fine, but my version only gives me a dropdown still.

I eventually just moved on to the other exercises honestly.

1 Like

I’ve mentioned this to some folks on our education team - let me see if they can help clarify.

You can double-click the cell you would like to edit. That displays a cursor, and you can edit the text just like any textbox. When you are done, you can press the enter key and the cell value is updated.

You repeat this process to edit the country names for this exercise. Once all your edits are done, then you can click on “Apply” on the bottom right of the window, and the output table is updated with the edits you made to the table.

1 Like

Hello @hayasaka , thank you for the suggestion.

I understand this is the standard solution, however, I am still not able to double-click. When I do that, the drop-down opens and this is all. In this case, the final name is not on the list so the dropdown list does not make much sense to me.

Is there any configuration I am missing? The node in the Solution file is working as you described - I can double-click and edit.

Thank you.

Yep, I used the Rule Engine Node to solve the problem, but this is still annoying me! :joy:

This is probably overkill, but you can try out the Value Re-Map component I built for user friendly clean up of column values used in categorization. It has a separate input option if you want to get your values from a different list, or you can use it like the example where you just use the same table / column in the second input as a value template. Once you configure it to the columns then you work in the Interactive View to do the re-mapping. You can filter values out of the dropdown list with the selection tool, and add them in using the manual entry table to the right. It also allows for writing and recovering of backup settings. Like I said, probably overkill… :rofl: It is the component on the right in the workflow below.

I just realize that this is for a learning exercise… The above component would probably fall firmly into the cheating category.

In general the trick to allowing manual entry into the Table Editor is to uncheck “Use domain of incoming table” in the editor tab. It is either dropdown, or manual entry per column. Otherwise you need to do what I did and have 2 columns which apply via formula.