5.1.0 Bug?

Hello - why does this happen in v5.1.0? I HAVE executed the flow and I see the data, but it still wants me to Execute the selected node.


Hi @sw1336
Unfortunately I cannot reproduce the problem. What are the steps to reproduce this? Does this happen all the time? Also, could you please give me some details about your operating system?

Hi @schramm - unfortunately, it occurs 100% of the time. I use Win 11 on an HP laptop. I haven’t done anything fancy like changing the config file, with KNIME.

There are no specific steps to reproduce this. Any node that has an output has the issue. Here are a few more examples:

As you can see, the node has been executed and there is data in it.

Row filter -

Group by -

Column Filter -

Thank you.

1 Like

Thanks for providing more information. We will try to reproduce this internally. Does it also occur after restarting the KNIME Analytics Platform?

I have created a bug ticket for it (NXT-1927 — “Execute” button located above the table)

1 Like

Yes, I have restarted KNIME and the box several times, but the same result.

Many thanks for creating the bug ticket.

more feedback on the bug.

If I wrap a couple of nodes into a Metanode that will have an output(s) and I select the Metanode, then the execute button is not super-imposed and the data is shown without any issue. But when a node is NOT wrapped, then the bug is there. 100% of the time.

Also, a Creator Node (table, variable, etc.) does not appear to have this issue. An executed Excel reader also does not have this issue.

It seems that only when you progress thru the WF, this issue occurs. Possibly a memory leak and/or not resetting properly kind of issue?

Thank you.

Hi @sw1336 ,

We tried multiple things, but we cannot reproduce the problem on our side. Could you please provide us some more information or parts of the workflow that leads to the problem. Or, is this in each and every workflow a problem? Are you running the KNIME Analytics Platform in a Virtual Machine?


1 Like

Hi @schramm,

Not much more detail I can really provide. Pretty much occurs in all parts except for Creator/Excel nodes. and no, I am not running KNIME in a VM instance.

Thank you.

Hi @sw1336
KNIME 5.1.0 hangs on MacBook pro after reboot. Here is the report. I tried a couple of times, but cannot pass the KNIME startup.

Screenshot 2023-08-21 at 9.18.09 AM

KNIME-5-1-0 Hangs on Macbook.txt (67.9 KB)

@schramm over to you…

Hi @kamleshp how did you get the report?

Btw, can you start knime from terminal, like

/Applications/KNIME 5.1.0.app/Contents/MacOS/knime

Then see the log, maybe it is easy to spot the issue

Same for me. I didn’t find any reason on single node status. Sometimes the dialog disappears, sometimes not. It is a workflow form version 4.7.4. … to load it into version 5 was as expected, everything works fine … only this dialog is boring … a bit.



Hi Schramm,

I’m on a new Macbook Pro and just downloaded the most recent version of KNIME (5.1).

Two things:

  1. I’m dealing with this same issue. When I click on a file reader node, the node output works great, showing me the table and statistics. When I click on a joiner node or column filter node to see the output table, a box covers part of the table saying “To show output, please execute the selected node”. The node has been executed, and the table is showing, but this pop-up box is covering it and will not go away, making for a frustrating experience.

  2. I like the concept of the node output at the bottom, but it would be great to be able to move it or have it “pop out” around as each time I want to see a larger table I have to resize my entire KNIME Analytics Platform. I also use multiple screens at work so the pop-out feature would allow me to move the output table section to another monitor.

Thank you.

1 Like

Hi @tdewagner

  1. Unfortunately we still cannot reproduce this — could you please share the workflow?
  2. We have started to implement this feature for the next release. So the idea is like you described to allow to pop out the port views.

Hi @sw1336,
do you still have the problem. And if so, is it possible to get the stack trace of the process ID via e.g. jstack, that would help us to dig deeper into the problem.

Yes, Schramm. I’d be happy to share the workflow. What email can I send it to?

If you don’t see the issue inside the workflow, I’m happy to do a screen recording as well.


We found a way to reproduce it. @mindUp and @sw1336 we adjusted some logic how the execute button was displayed. The changes of the “NXT-1927: Execute button is above the table” bug is part of the recently released KNIME Analytics Platform 5.1.2 bugfix release. Could you please check if it is now gone for you.


Hi @schramm - it seems to be fixed in my initial testing. Will continue to look out for this one and will report again as needed.

Many thanks for your assistance!!!

For me it’s fine now. Never faced the problem again in 5.1.2
Thank you!