Add User and consumer on KNIME Server 4.12 with psw and group

Hello,

I installed KNIME Server 4.12 and everything was fine.
The new possibility to configure the server (inclusive Groups of user and conumer) are great but I have a Problem.

How can I set up a new user, put him in a group and give with a Password ?

Sorry, may be I oversee the right button but in half a day I still haven’t found it.

Thank you,
Roberto

Hi Roberto,
Maybe you are confused by the “Add group” button? This one just adds a new group. To add a user to a group, just check the box next to the group you want to add the user to. The password can be entered on top of that and then you just click the Submit button. Does that make sense and work for you?
Kind regards
Alexander

Hallo Alexander,

I feel really embarassed… I don’t find either add group nor add user.
in Attachment a screenshot of my server startpage and Administaration -> Configuration and Administration -> license



I have the choice in 2 submenu:

Monitoring -> (jobs - schedule- executors - logs)
Administration -> (license - Configuration)

in Administration - Configuration (where I expected to add user) there is no “add” button. I can only set variables as

com.knime.server.login.consumer.allowed_groups
com.knime.server.login.user.allowed_groups

Where can I find this “add group” or “add User” button ?

Thank you in advance,
Roberto

Hi Roberto,
That is quite strange. For me it looks like in the screenshots below. As you can see, I have users and groups under Administration. I will investigate how it can happen that those items are not shown. Do you see any error messages in the log files (most likely the localhost.yyy_mm_dd.log)?
Kind regards,
Alexander


Hi Roberto,
Do you maybe not see this because you have the local user management disabled and only LDAP to supply the server with users?
Kind regards,
Alexander

Hi Alexander,
we installed the server in a standard way on a new virtual server because we want now a TEST Environment to avoid Realease update Problems on the PROD Environment. The Hardware of the Test Environment is new and there were no KNIME installed before.

I don’t think and don’t remeber we already activated the LDAP authentification. We just installed first the server from the package. We want to altivate the LDAP Authentification in januar, but may be you can tell me where can I check/deactivate the LDAP authentification.

Thank you,
Roberto

Hello Roberto,
The LDAP settings are made in the server.xml and in there you can check if you have an element starting like this:

<Realm   className="org.apache.catalina.realm.JNDIRealm"

Let me know if you need further help. We can also have a call this week if you want.
Kind regards,
Alexander

Hi Alexander,

option is mark as comment (deactivated). I send you the server.xml
We still have no modifications. We just made the standard installation.

I have no Idea what could be the error. May be we can discuss it in a call or if you want you can see the server setup.

Thank you,
Roberto

Hi,
For everyone else landing here because of similar issues: on the Server a couple of files were not accessible because the service was run not under the correct user. This is why the database file for local user management was not available and therefore also not visible in the WebPortal.
Kind regards,
Alexander

1 Like

The Problem is that in our Enterprise no technical user is allowed to be admin. Admin are only physical person.
So the Server is running with a technical user as “application manager”. So if the service is started from the technical user it has not possibility to set new user or group.

@tebaldir It is important to note, though, that KNIME Server should not be run under an admin account. It should run under an account that has read and write access to all server files.
Kind regards,
Alexander

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.