Amazon Auth Error

Amazon Auth_Error

Please need help to fix the above error, i am using ‘Amazon Authentication’ node

Thanks

Hi @Prag_Mor

It seems that you cant authenticate because you have certificates missing for the connection.

Have you installed the necessary certificates in your KNIME AP cacerts file? You can do this following the client configuration part in the documentation

If you have your certificates installed and still get this error, this could indicate some other process (like a virus scanner) that intercepts the connection and replaces the certificate? If so, I would advise you to contact your IT department.

Best wishes
Ana

2 Likes

Thanks @ana_ved
Will check this and update

@ana_ved

I have not installed any certificate, In Client Configuration part its mentioned

  1. Get the CA’s certificate in PEM format.

not sure what is CA’s certificate?

Hi @Prag_Mor

Sorry for the delayed reply.

The CA means Certificate Authority. Perhaps someone in your IT company could help you obtaining it?

1 Like

np @ana_ved

Please share me more details about PEM format. What i have to ask to our IT?

Thank you

Hi @Prag_Mor

the certificate is basically a file, that tells your PC who the server is and that that server can be trusted. If an attacker mimics the server, this would be noticed and the communication with the attacker would fail.

Your IT department should be fairly familiar with certificates. They just need to know for which server/service you need the certificate.
So, I’d give them a bit of context, to make everything as clear as possible:
You are using KNIME Analytics Platform to connect to Server XYZ and you need a .pem certificate for that server to add it to your keystore. (If you want, you can also link them the guide, so that they know what exactly you are doing)

PEM is simply the file format, see certificate - What is a Pem file and how does it differ from other OpenSSL Generated Key File Formats? - Server Fault

I hope this helps :slight_smile:

Kind regards
Marvin

2 Likes