Anaconda Integration: Could not find Python executable at the given location

#1

Hi,

I try to set up a Python/Anaconda environment. I followed the guide (https://www.knime.com/blog/setting-up-the-knime-python-extension-revisited-for-python-30-and-20) and ended up with this error within the preferences section of KNIME when trying to apply the settings:

"Could not find Python executable at the given location" -> see screenshot attached.

The output of either a Python 3.5 or 3.6 environment from the command line looks like this:

(knime_py35) F:\Anaconda\envs\knime_py35\etc\conda\activate.d>set "KERAS_BACKEND
=theano"
Python 3.5.4 | packaged by conda-forge | (default, Aug 10 2017, 01:38:47) [MSC v
.1900 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>>

(knime_py36) F:\Anaconda\envs\knime_py36\etc\conda\activate.d>set "KERAS_BACKEND
=theano"
Python 3.6.3 |Anaconda, Inc.| (default, Oct 15 2017, 03:27:45) [MSC v.1900 64 bi
t (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>>
 

My environment: Windows Server 2012, KNIME 3.4.x, Anaconda3 5.0.0.

Thanx for any kind of help!

Kind regards

0 Likes

#2

I can't see a screenshot. Can you show us where you are in the KNIME preferences and what you are entering there?

0 Likes

#3

Sorry, I've seen the image now - not sure why I didn't/couldn't before.

Have you confirmed that your batch file runs correctly from the command line? In other words, if you execute knime_py35.bat myfile.py does it activate the correct environment, start Python and run myfile.py?

In my KNIME config - which I think I set up before the blog post appeared, and it seems to work OK so I haven't changed it - I set 'Path to Python 3 executable' to the actual path of python.exe in the Anaconda environment. In your case I think this would be

F:\Anaconda\envs\knime_py35\python.exe

Does it work if you try that?

0 Likes

#4

Hi Tom,

thanks for your help. As I mentioned: Executing the .bat file opens a python CLI perfectly fine although I didn't try to run a seperate python script for further tests. But I figured out that after updating the KNIME environment it now recognizes the python executable. I will try to run some scripts during the day.

 

Have a nice weekend.

0 Likes

#5

Although this thread is a bit older, just wanted to mentioned that the Python-nodes’ default settings are set to Python2. If you want to use Python3 you need to change the setting in the node’s option tab. Otherwise you run into exactly this error.

1 Like