Association Rule Learner(Borgelt) created an empty data table erro

Hi,

I am creating an Market Basket Analysis in KNIME to try to find patterns.
Here’s a screenshot of my workflow as of the moment:

image

Double Input configuration:

image

Here’s my data set.
Data set 1:

Data set 2:

Here’s my Association Rule Learner(Borgelt) configuration:

image

Error details:

ERROR Association Rule Learner (Borgelt) 2:110 Temp folder “C:\Users\USER\AppData\Local\Temp\knime_Workflow Manage29078” does not exist (associated with node context “Association Rule Learner (Borgelt) 2:110 (EXECUTING)”) - using fallback temp folder (“C:\Users\USER\AppData\Local\Temp”
ERROR Association Rule Learner (Borgelt) 2:110 Temp folder “C:\Users\USER\AppData\Local\Temp\knime_Workflow Manage29078” does not exist (associated with node context “Association Rule Learner (Borgelt) 2:110 (EXECUTING)”) - using fallback temp folder (“C:\Users\USER\AppData\Local\Temp”
WARN Association Rule Learner (Borgelt) 2:110 Node created an empty data table.

You settings say to cover art least 10% of all cases if you reduce that to 1 or 2 you might have a better chance to get results.

Thanks for checking. I tried to change the minimum support to 1 or 2 but still it returned an empty table.

Any chance you could share the data or something similar. I would have to think of what could be going on here.

Hi mlauber71

Sorry but i am not able to share the data since this is client data. When i tried to play with the value of the minimum support in the double input node it returned this error:

ERROR Association Rule Learner (Borgelt) 2:110 Temp folder “C:\Users\USER\AppData\Local\Temp\knime_Workflow Manage29078” does not exist (associated with node context “Association Rule Learner (Borgelt) 2:110 (EXECUTING)”) - using fallback temp folder (“C:\Users\USER\AppData\Local\Temp”

Here’s the value that i used:

Double input node
image

Association rule learner node:
image

Maybe you could reset it, clear the log and run it again since I do not understand why it keeps mentioning problems with temp folders.

Hi mlauber71

I already cleared it multiple times and it keeps saying the error: using fallback temp folder

Weird! Does the problem persist over a KNIME restart? If so, how can we reproduce? Maybe you can tweak this public example and ‘break’ it?:

https://hub.knime.com/knime/workflows/Examples/50_Applications/16_MarketBasketAnalysis/01_Build_Association_Rules_for_MarketBasketAnalysis*fQ9yZLztzEUmAsQ0

2 Likes

Question was if you could share the log so we might get an idea. If you could break an open example it would be even better

Actually that’s the workflow that i used. I just modify it.
I already restarted my KNIME yesterday but the issue of “node created an empty table still persist”

This is the error from the console:

ERROR Association Rule Learner (Borgelt) 2:110 Temp folder “C:\Users\USER\AppData\Local\Temp\knime_Workflow Manage29078” does not exist (associated with node context “Association Rule Learner (Borgelt) 2:110 (EXECUTING)”) - using fallback temp folder (“C:\Users\USER\AppData\Local\Temp”
ERROR Association Rule Learner (Borgelt) 2:110 Temp folder “C:\Users\USER\AppData\Local\Temp\knime_Workflow Manage29078” does not exist (associated with node context “Association Rule Learner (Borgelt) 2:110 (EXECUTING)”) - using fallback temp folder (“C:\Users\USER\AppData\Local\Temp”
WARN Association Rule Learner (Borgelt) 2:110 Node created an empty data table.

Just an update when i tried to play with the double input value. I put 0.008

minsupport

and restart my workflow the association rule learner(borgelt) is stock up to 70% and after 10 minutes of processing it returned an error of:

version 6.22 (2016.04.09) © 1996-2016 Christian Borgelt
reading C:\Users\USER\AppData\Local\Temp\isInput2291508654966416947.txt … [2964 item(s), 458 transaction(s)] done [0.00s].
building transaction tree … [459 node(s)] done [0.00s].
checking subsets of size 1 2 3 4 5 6 7 8 9
C:\Program Files\KNIME\plugins\org.knime.ext.itemset_3.7.0.v201808081048\resources\executables\win\x86_64\apriori.exe: not enough memory

Take note that my data set is not that large it just contains only 2,900 rows of data.

According to the log the apriori executable ran out of memory. This is not the KNIME memory (which you could otherwise tweak in the knime.ini) but the memory that is used by the executable that KNIME calls out to. For what I know it uses all memory that is (left) available on the machine.

Apriori is very sensitive to settings, especially “minimum support”. Small changes can let the search space explode and that is very memory intensive. You’ll get tons of results (or apparently none at all if memory overflows). Increase the support value.

I’ll open a ticket to do better error handling in case the executable fails with memory errors. But the actual problem is that your search settings are too relaxed.

Hope this helps.