AWS Upgrade Analytics Platform to 3.1 - Manual Process

According to the docs, in order to get the AWS-flavored KNIME (small) instance up to 3.x it is required to manually install the Analytics Platform. I downloaded the tarball to the server and extracted the files to execute the ‘knime’ executable. I used this (and the video) as a guide for Linux: https://www.knime.com/installation

I’m working solely via CLI

First I got an error about SWT-GTK files and found that I needed to run the command sudo apt-get install libwebkitgtk-3.0-0. I did that and it resolved the error.

Now I am stuck on starting the the AP service because it cannot open the display. How do I run this headless as a service? Am I confusing something between Knime Server and Knime AP?

CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
Unable to init server: Could not connect: Connection refused
Knime: Cannot open display:
Unable to init server: Could not connect: Connection refused
Unable to init server: Could not connect: Connection refused
Knime: Cannot open display:
Knime:
An error has occurred. See the log file
/opt/knime/knime_4.3.1/configuration/1614965858736.log.

EDIT: it seems I also need to download the Server Executor (KNIME Server Administration Guide)

So, I need to manage the download, installation, and versions of 3 different KNIME services in order for the AWS server to function on the latest version? This is borderline ridiculous for the cost of the server on the AWS marketplace.

@MichaelRespondek - you helped me initially (request (19204)) and pointed out the AWS disk swap which would be nice if AWS had the latest 4.3.1 build of KNIME but it is stuck on 4.2.x and the typical upgrade process requires manual installation which is what I’m troubleshooting above.

I am following this process (Updating from KNIME Analytics Platform 4.2.x and older)

Due to some larger changes, it is not possible to upgrade to KNIME Analytics Platform 4.3.1 from a version older than 4.3.0. Therefore, you need to install KNIME Analytics Platform 4.3.1 from scratch and install the KNIME Executor connector version 4.12 into it.

To install KNIME Analytics Platform 4.3 from scratch you will need to run it as the user that owns the Installation.

Please refer to the KNIME Server Administration Guide for more details about installing a KNIME Executor.

In the end, when I downloaded the executor is was a “knime-full” file that looks like it had all the executables in it including the Analytics platform- very confusing. The executor starts but I don’t know what that does. When executing the ‘knime’ executable, it gives the same error as before:

org.eclipse.swt.SWTError: No more handles [gtk_init_check() failed]

Can someone please help me get the AWS Instance upgraded to 4.3.1? This is getting out of hand.

Hello Chase,

I have reached out to you on your existing case to provide further assistance. Please check your e-mail and we can work towards resolution further there.

Thank you,
Nickolaus

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.