"Bar Chart" does not respond to to selection events

Dear Knimers,

I have the following table:


I have created a component to display this information in a component view:



So far so good.

But, if I now deselect “shrews”…

…then the dot corresponding to shrews disappears from the scatter plot, but not the corresponding bar from the bar chart.

…even though “subscribe to selection events” is checked.


KNIME_project25.knwf (14.4 KB)

I think it’s worth noting that in these nodes there seems to be a difference between “selection events” and “filtering events”. The Interactive Value Filter Widget controls filtering events.

In the Scatter Plot node configuration, you can choose whether it responds to these filtering events:

Some nodes do not support interactive filtering, and it looks like the Bar Chart node is one of them. There is no option here to respond to filtering events.

One workaround would be to use the Refresh Button Widget which places a refresh button in the component view which re-executes downstream nodes when pressed.

However in this case it’s not necessary. If instead you use the Nominal Row Filter Widget and configure it to re-execute on widget value change (on the Re-execution tab), I think you’ll get your desired behavior.



That was really helpful @elsamuel!!

You actually answered a question that I posted a long time ago: https://forum.knime.com/t/i-do-not-understand-nominal-row-filter-widget-behavior-in-a-component :smile:

Back then this “re-execution” functionality did not yet exist I think…

Many thanks!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.