Batch command line option not honoured for node within Component

Hi Team,

I am having a ‘CSV Reader’ node within a Component and trying to control its value via ‘-option’ in my batch execution. The command option looks like:


When I execute the batch command, I get the below warning:

WARN main BatchExecutor No node with id [460, 143] found.

and the ‘CSV Reader’ node’s value is not controlled by the file passed in the ‘-option’.
At the same time, if I convert the Component into a Metanode, the node value is controlled by the file specified in ‘-option’.

What should be the correct way to specify the ‘-option’ to control a node within Component?


Hi @ravikiran,

Components can not be controlled via the -option parameter. You can use metanodes or wrap your component in a metanode that exposes the parameters you want to controll.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.