Batch Mode Error Connecting to Custom Database

Hi Everyone!

I’m running Knime version 5.2.1 where I can run a workflow interactively. However, when I try to launch it in Batch Mode with the consol logs, I get this error:

ERROR main Node Loading model settings failed: Could not find the [sql_server] database driver.
org.knime.core.node.InvalidSettingsException: Could not find the [sql_server] database driver.
at org.knime.database.node.connector.DBSessionSettings.validatePrimaryIds(
at org.knime.database.node.connector.DBSessionSettings.validateSettings(

The sql_server in the error refers to a driver we created in databases.

From this post, Run KNIME 4.3 in batch mode with preferences - #7 , it looks like I need to include -preferences. However, when I search in my Workspace.metadata.plugins\org.eclipse.core.runtime.settings folder I only see files ending in .prefs, none with an .epf extension. Can someone point me to where I would find the correct preference file to add this location to the batch?

I really appreciate your help!


I figured out how to correct this! I went to the Classic UI and then was able to export the preferences file. After pointing to that preferences file, this worked perfectly.

1 Like

Thanks for posting your solution to benefit everyone!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.