Batch mode issues (linux)


I am trying to set up batch mode to be able to run scheduled workflows, starting with one that works fine in the GUI. I read up here:

But even entering

knime -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION​

throws an error, logging to the configuration directory of the KNIME installation folder (see attached). What stands out is the following:

java.lang.RuntimeException: Application "org.knime.product.KNIME_BATCH_APPLICATION​" could not be found in the registry.

Is my installation lacking something?


1700479071256.log (3.5 KB)


The problem remains when I run it from under the installation directory. There are no extra spaces anywhere in my command:

evehom  /  opt  knime  knime_5.1.0  knime -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION​

CompileCommand: exclude javax/swing/text/GlyphView.getBreakSpot bool exclude = true

After this the error message window pops up, stating:

An error message has occured. See the log file /opt/knime/knime_5.1.0/confugurations/xxx.log for details

I sincerely hope this can be solved without reinstalling KNIME and all the nodes…

OK, so I downloaded 5.1.2 and quickly tested the command

knime -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION

It still throws the CompileCommand warning but after that I see all the batch mode options in the terminal.

So apparently something funky with my 5.1.0 installation…

Thanks for your suggestions/Evert

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.