BERT by Redfield -- bert is missing


I tried to use BERT by Redfiled. The problem is that when I try to execute BERT Model Selector node, it gives me an error – could not start python; bert library is missing.
I installed everything and followed all the instructions out there (including other KNIME forums), but it did not help. I also clean installed everything on another machine (on both, windows and MacOS), but the results were the same.
Would really appreciate your help!

@Artem @Redfield, I tried running this Redfield Bert workflow by following these instructions and ran into the same issues as ac2089. I also made a requirements.txt file to use this BERT node and ran into conflicts when attempting to upgrade. requirements.txt (273 Bytes)

Hello @ac2089

It is hard to understand what is wrong with your set up without any logs or stack trace. So the only suggestion I have now - is to install β€œbert” package.

I have also updated the workflow that @victor_palacios mentioned, now it has Conda Environment Propagation node, that can help you compare the packages and the versions or you can create a Python environment from scratch using this node as well. Please try this one.

1 Like