Big Query Connector : Execute failed: com/google/auth/Credentials


like i said in the email subject, i have the following error when i try to connect Big Query with “google big query connector”.

This is the workflow and i can’t execute the node:

Does anyone know why he shows up?


Hi @Chrim,

Welcome to the KNIME community!

The error message is somehow confusing. You have to add a Google Authentication or Google Authentication (API Key) node in front of the BigQuery connector.


Hi @sascha.wolke,
i try to add google authentication, but which directory should I add? In my company my colleagues start the workflow with google big query connector.


Hi @Chrim,

You don’t have to select a directory. Select the first option (Memory) and click on the Sign in with Google button on the top.


But if i choose the scope “google big query connection” shows up this error, i can’t connect with Memory.

Hi @Chrim,

Sorry about the confusion, you should use the Google Authentication (API) node.

You can find more information here: KNIME Google Cloud Integration User Guide


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.